Talk2m - Network issue on Datamailbox servers – Incident details

All systems operational

Network issue on Datamailbox servers

Resolved
Major outage
Started 9 days agoLasted about 15 hours

Affected

Europe

Operational from 3:34 PM to 6:37 AM

Rest of Europe

Operational from 3:34 PM to 6:37 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Talk2m experienced a degradation of service since 19 June 2025 03:34pm UTC.

    Because of degraded network performance on DMBOX server located in Roubaix (France).